How can we improve Leganto?

Support presentation of reading lists in an iFrame within VLE / LMS

Ex Libris currently do not recommend integrating Leganto reading lists within a VLE / LMS using an iframe, as there is an issue with cookies.

Users receive an "Illegal Institution" message on certain browsers (eg. Safari on macOS) with the cookie policy as in browser default.

We would like to ask for this issue to be re-investigated by Ex Libris and an alternative proposed for roadmap development that fixes the issue without inelegant workarounds such as manually altering browser cookie policies or using a different web browser - noting that these workarounds are not always possible for users depending on local security policies.

Background:

At Imperial College London we have been using Blackboard LTI integration with Leganto within an iframe since launch. This is based on our academics' view that it is particularly important to ensure reading lists are presented in the same place students go for all other aspects of online learning, rather than directing students over to another campus system.

We believe this issue is a widely felt one, therefore we ask sites that agree to up-vote this idea.

The attached screenshot demonstrates how the iframe integration appears within Blackboard using LTI.

69 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Andrew Preater shared this idea  ·   ·  Admin →

    31 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Paul Harding commented  · 

        Hi Gal

        Thanks for the update and the fix - we're testing and it looks to be working which is really good news.

        Best wishes

        Paul

      • Blake Galbreath commented  · 

        Hi Gal,

        I tried this on Chrome, FF, Edge, and Safari - all appear to be working so far.

        Thank you!
        Blake

      • AdminGal Darom (Admin, Ex Libris) commented  · 

        hi All,
        The BB fix is now available in Production.
        The fix was tested, and seem to be working well.
        Please look into it and let us know your test results

        kind regards,
        Gal

      • Paul Harding commented  · 

        Hi Gal

        Details from York are as follows:

        Course Delivery (3100.0.3-rel.51+917ccd3)
        Community Engagement (3100.0.3-rel.51+917ccd3)
        Content Management (3100.0.3-rel.51+917ccd3)

        Paul

      • Blake Galbreath commented  · 

        Hi Gal,

        That sounds great, thanks. In case you need what Chris suggests:

        Blackboard Learn ™
        Course Delivery (3200.0.3-rel.75+4185aa5)
        Community Engagement (3200.0.3-rel.75+4185aa5)
        Content Management (3200.0.3-rel.75+4185aa5)

        Blake

      • Chris Jones commented  · 

        Agree, many thanks.
        Experience same as York and Washington state, although LTI tool links only in course menu at the moment, not content pages.
        Should we be looking to confirm versions of BlackBoard in use for comparison?

        e.g. (see 'installation details' link at bottom of BB login page):
        Blackboard Learn - Course Delivery (3200.0.2-rel.37+f07d42b)
        Community Engagement (3200.0.2-rel.37+f07d42b)
        Content Management (3200.0.2-rel.37+f07d42b)

      • Paul Harding commented  · 

        Hi Gal

        Thanks to you and the development team for identifying the problem. We look forward to the fix being deployed next week.

        Best wishes

        Paul

      • AdminGal Darom (Admin, Ex Libris) commented  · 

        Hi,
        We identify the issue, it is related to Blackboard specifically, the fix is now in QA.
        We plan to inject a fix early next week.

        Thank you for your immediate responses, it was very helpful.

        Kind regards,
        Gal

      • Paul Harding commented  · 

        Thanks for getting back to me, Gal.

        We are testing in Blackboard. I've been unable to get the new text to display in any of the browsers I've tried - Chrome, IE, Safari, and Firefox.

        I've tried completely clearing the cache etc., but am still seeing the original message.

        You can find screenshots of my Alma/Chrome settings etc. here:

        https://docs.google.com/document/d/1giQp6kUhYbn5pgcTr8QQH5m-yrGoJQtruLxvgoizGy8/edit?usp=sharing

        Let me know if you need any further information from me.

        Best wishes

        Paul

      • AdminGal Darom (Admin, Ex Libris) commented  · 

        hi,
        (we just came back from holidays sorry for the delayed reply)
        We are looking into it.
        I will also need your help, as much as you can, with providing more details.
        e.g. browser type, browsers's 3rd cookies configuration (screen capture if possible) , and CMS/VLE used.

        Please first test it on chrome to validate the fix.
        Click the below link to see how to configure and test it on chrome browsers.
        https://box.exlibrisgroup.com/owncloud/public.php?service=files&t=5d6c261d6fadee5ff3ac2b03b89104f8
        (password 123456)

        Kind regards,
        Gal

      • Paul Harding commented  · 

        Hi Gal

        I'd appreciate an update on this, please.

        Thanks v much

        Paul

      • Jim Adamson commented  · 

        Me neither, same as before. Please fix the fix ;-)

      • Blake Galbreath commented  · 

        Hello,

        I am not seeing any new behavior in Chrome or Firefox either. I have enabled the setting in Alma (true) and cleared all cache/cookies.

        Blake

      • Paul Harding commented  · 

        Hi Gal/All

        Is anyone seeing the new text? No matter what I do, if I have third-party cookies blocked I am getting the 'illegal institution' message. I've tried clearing out the cache etc.

        Thanks

        Paul

      • Paul Harding commented  · 

        Thanks, Gal. I've changed the setting as instructed but am still seeing the old 'illegal institution' message. Am I missing something?

        Paul

      • AdminGal Darom (Admin, Ex Libris) commented  · 

        hi all,

        The fix is available in production now.
        Please, first enable the new functionality >> Leganto customer setting : 'enable_3rdparty_cookie_blocking' set to true.

        Please update me for any issue.

        kind regards,
        Gal

      • Chris Jones commented  · 

        Hi,

        If not configurable, I would press for erring on the side of vaguer terminology in the text (some institutions have decided preferences (and this only in English!) for 'Reading List' vs. 'Resource list', so to refer to Blake's clear explanatory phrases it may be better to use only 'list' or 'lists' in terms.

        "If you are having trouble opening your [reading] lists, please click the button below to open them in a new tab:"

        For me a little more context would help (or link to more information - a leganto help page even!)

      • AdminGal Darom (Admin, Ex Libris) commented  · 

        Good news.

        We are planning to inject a fix next week, that will deal with the problem described below.
        The new functionality will be flag based (disabled).
        Text will not be configurable and will as Blake wrote in his reply.

        i'll update as soon as the functionality is available.

        kind regards,
        Gal

      ← Previous 1

      Feedback and Knowledge Base